About Ink

This printer uses the FINE cartridges of the following numbers:

Black : PG-210XL

Color : CL-211XL

Black : PG-210

Color : CL-211


About Ink

This printer uses the FINE cartridges of the following numbers:

Black : BC-310

Color : BC-311


About Ink

This printer uses the FINE cartridges of the following numbers:

Black : PG-810XL

Color : CL-811XL

Black : PG-810

Color : CL-811


About Ink

This printer uses the FINE cartridges of the following numbers:

Black : PG-512

Color : CL-513

Black : PG-510

Color : CL-511


About Ink

This printer uses the FINE cartridges of the following numbers:

Black : PG-815XL

Color : CL-816XL

Black : PG-815

Color : CL-816